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Session Description 

Overview 
Want to learn how to create your own Web pages or brush up on your Web editing skills? Creating Web 

pages and managing your Web site with Dreamweaver is easier than you might think. This workshop 

introduces you to the Dreamweaver environment and its basic Web editing tools. Topics include 

creating a new Web document, defining a site, adding new content and importing existing text from 

Microsoft® Word, formatting text and inserting images. 

Prerequisites Individuals taking this workshop should also have basic computer skills, knowledge of the 

Web, basic Web browser skills, and the ability to effectively work in the Windows or Macintosh OS 

environment. 

Objectives for participants attending this TLC session: 

Attain a beginning understanding of the Dreamweaver environment. 

Use Dreamweaver to: 

• Create a new Web document. 

• Define a Site. 

• Add new content from a Microsoft Word document. 

• Format and style text. 

• Insert images. 

Introduction to Dreamweaver 
Adobe Dreamweaver CC17 is a full-featured Web design suite that allows you to create and edit HTML 

and XHTML documents (Web pages). With Dreamweaver, as with other HTML and XHTML editors, 

knowledge of the XHTML mark-up language is not required to create professional-grade websites. 

Unlike many Web editors, Dreamweaver is a palette environment. This means that the user interface is 

a series of windows or palettes, called panels, which can be moved around the screen by the user. 

The remainder of this document will use screen samples from the Windows-based version of 

Dreamweaver CC.  
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Document Window 

The Document window contains the toolbar, document title, file name, Code View window to view the 

HTML and XHTML code, the WYSIWYG window to view your Web page graphically (Design View), and 

Split Code. 

This window will allow you to create a new website or edit an existing website. The screen has three 

sections. 1. Site definition folder, 2.DOM (Directory Object Model) Panel, and 3. Page/Site Preview Panel 

 

 

The Standard view displays the files menu a realistic representation of what your document will look 

like in a browser, and lets you interact with the document exactly as you would in a browser. You can 

edit HTML elements directly in Live View and instantly preview your changes in the same view as well. 

For more information on editing in Live View, see Edit HTML elements in Live View. 

Developer view is a design environment for visual page layout, visual editing, and rapid application 

development. In this view, Dreamweaver displays a fully editable, visual representation of the 

document, similar to what you would see when viewing the page in a browser. 

Code view is a hand-coding environment for writing and editing HTML, JavaScript, and any other kind of 

code. 
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Toolbar 
The toolbar is part of the Document window and allows you to toggle between the Code view and 

design view windows, set your title page, adjust your view and access the other Dreamweaver tools. 

Notice the menu options at the top of the screen, File, Edit, View, Insert, Tools, Find, Site, Window and 

Help 

 

Additionally, you can adjust your screen layout by selecting the Standard Menu Drop down menu 

  

Notes: 
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Getting Started  

Create a New File 
Most Web pages you create will be simple HTML pages. The steps below show you how to create a new 

HTML document. 

Step 1. Click the File Menu and select new.  The New document window appears 

 

 

Step 2. From the New Document window, select document type HTML 

Step 3. Optionally, you may select a specific layout for your new web page other than a blank one by 

selecting a starter template 
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Open an Existing File 
Step 1. Click the File menu and select Open 

 

Step 2. From the open window, select the file you want to open (click the file name) and click the open 

button.  Dreamweaver will now open your document in the Document window. 
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Create a New file from an Existing File 
Step 1. Open your existing file using the previous steps 

Step 2. Click the File menu and choose Save As. 

 

  

Step 3. Dreamweaver will now open your “Save As” document window in the Document window. Give 

your file a new name. Be sure the file ends with either “htm” or “html”. (Do not include the quotation 

marks). 
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Saving Your Document 
To save your document, choose the Save or Save As option under the file menu. After you save your 

document will appear in the Files panel as a file 

If your Files Panel is not visible, you can activate it from Windows Files, or be pressing the “F8” key. 

 

 

Notes: 
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Creating a site 

New Site 
To create a new site Select the Site Option from the dropdown menu, then select the New Site option 

 

The following dialogue box will display 

 

Enter the site name in the field labeled site name, please note that this name is a reference for yourself. 

Next, using the mouse click on the folder image next to the Local Site Folder field. This will allow you to 

place the files and images for your website on your local machine for transfer to the Birdnest webserver 

(http://www.birdnest.org/username). 

 

http://www.birdnest.org/username
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Next, the Choose Root Folder menu will display 

 

  

Select the location to store the website files from the left panel of the “Choose Root Folder” menu. 

Next, click the Select Folder button. 

Now set the location of the images for the website. 

 

 

By selecting Advanced Settings from the left panel     

Then the Local Info option   
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You can select the default location for the images by clicking on the folder next to the Default Images 

Folder field. 

 

Now select the folder in which you want to save images for the website. Click the select folder button 

and you are now ready to design your new website. 
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Managing Sites 
The next section will walk through how to setup your connection to your Birdnest and/ or Faculty 

websites. 

Manage your existing site using Dreamweaver, go to Site > Manage. Click New to set up a new site, or 

select an existing Dreamweaver site and click the edit icon. 

 

To manage a website on your local computer, select Site in the left panel 
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Next, locate and click on the “+”, plus sign approximately ½ way down the screen. 

 
This is the “add” server button. You can add a new server or select an existing server and click the Edit 

Existing Server button. 

Birdnest Settings 
Below is an example utilizing the Birdnest server (http://www.birdnest.org/username) basic setup 

options tab. 

 

 



 Winthrop University – Technology Services - Spring 2018 
An introduction to Dreamweaver 15 

In the Server Name text box, enter http://www.birdnest.org  

 

Select SFTP from the Connect Using pop-up menu. 

 

 

In the SFTP Address text box, enter the address birdnest.org 

 

Note: Port 21 is the default port for receiving FTP connections. This needs to be changed to port 22 in 

order to place a secure connection to the Birdnest server (http://www.birdnest.org). 

 

In the Username and Password text boxes, enter the username and password that you use to connect to 

the SFTP server. For example, if your username is smithj2, then you would enter acc/smithj2 and your 

password. 

 

  
In the Web URL text box enter the URL of your website (for example, http://www.birdnest.org/smithj2). 

Dreamweaver uses the Web URL to create site root-relative links, and to verify links when you use the 

link checker. 

  

http://www.birdnest.org/
http://www.birdnest.org/


 Winthrop University – Technology Services - Spring 2018 
An introduction to Dreamweaver 16 

Faculty Website Settings 
Below is an example utilizing the Faculty web server (https://faculty.winthrop.edu/username) basic 

setup options tab. 

 

In the Server Name text box, enter https://faculty.winthrop.edu/ 

 

Select SFTP from the Connect Using pop-up menu. 
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In the SFTP Address text box, enter the address birdnest.org 

 

 

Note: Port 21 is the default port for receiving FTP connections. This needs to be changed to port 22 in 

order to place a secure connection to the Faculty web server (faculty.winthrop.edu). 

 

In the Username and Password text boxes, enter the username and password that you use to connect to 

the SFTP server. For example, if your username is smithj2, then you would enter acc/smithj2 and your 

password. 

 

 

In the Web URL text box enter the URL of your website (for example, 

http://faculty.winthrop.edu/salters). Dreamweaver uses the Web URL to create site root-relative links, 

and to verify links when you use the link checker. 

 

 

Testing the connection 
 

Dreamweaver saves your password by default. Deselect the Save option if you prefer that Dreamweaver 

prompt you for a password each time you connect to the remote server. 

 

Click Test to test your SFTP address, username, and password. 
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In the Root Directory text box, enter the directory (folder) on the remote server where you store 

documents that are visible to the public. 

 

 

Next click, the save button  and then the done button  Now click 

both the connect and sync buttons, to be fully connected to your server. 

 
 

 

Notes: 
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Editing Webpages 
 

Insert Menu 
The Insert panel contains various icons that allow you to easily insert different type of elements into 

your Web documents, for example, insert a table, picture, image, hyperlink or header. 

 

  



 Winthrop University – Technology Services - Spring 2018 
An introduction to Dreamweaver 20 

Editing Text Properties 
Indenting or Outdenting a Paragraph – creating visual separation 

You can increase / decrease indent text functions from the edit drop down menu. This function will 

increase or decrease the paragraph or text selected on the page. 

Step 1. Place your cursor on the page where you with to outdent or indent the paragraph  

Step 2. Select Edit 

Step 3. Select Text 

Step 4. Select Indent or Outdent 
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Format Paragraph 
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Page Properties 
You can access the Page Properties dialog box from the Modify menu or from the properties panel (as 

long as you have not selected an image). 

Step 1. Click File and then select Page Properties from the drop down menu. 

Step 2. The page properties dialogue box allow you to define the background, text, and link colors as 

well as a page title, among other items. 

The list of page properties window depends on whether or no you are using Cascading Style Sheets 

(CSS). Below is the main properties window show the appearance (CSS) tab. 

 

  



 Winthrop University – Technology Services - Spring 2018 
An introduction to Dreamweaver 23 

Previewing in a Browser 
You can preview your web pages in a Web browser by selecting File Real time View and then select the 

browser you wish to use (Mozilla Firefox, Google Chrome, Internet Explorer, Microsoft Edge) or by 

pressing the “F12” key to launch the default browser. 
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Exercise 1. Modifying Page Properties 
 

1. From the Dreamweaver document window, create a blank HTML page.  

2. Save the file as DW_Exercises.html 

3. Add a page tile and change the background color of your document 

4. Insert a paragraph to your webpage and save it 

5. Preview your document in Google Chrome or Firefox   
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More webpage editing 

Adding Content from a Microsoft Word document 
You can easily copy and paste content from a word processing software (Microsoft Word for example) 

directly into your Dreamweaver document. 

This can save you valuable time, especially if you have a lengthy document. Unfortunately, you may lose 

some of your formatting during this process. 

How to copy and paste from a word processing software: 

Step 1. Open your document with a word processing software such as Microsoft Word.  

Step 2. Select your text using the cursor and/or mouse. 

Step 3. Copy your text: In Windows press CRTL + C or Command+C on the Macintosh 

Step 4. Open your HTML or XHTML document in Dreamweaver, then place the cursor in the document 

where you want to past your content. 

Step 5. Paste your content into your Dreamweaver document using either Edit > paste or Edit > Special 

Paste (CTRL + V, CRTL+SHIFT+V  or Command+V on the Macintosh) 

 

 

Notes: 
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Indenting Headers and Creating Lists 
 

The header element represents a container for introductory content or a set of navigational links. 

A header element typically contains: 

• one or more heading elements (<h1> - <h6>) 

 Normally, the higher the number, the smaller the text of the header 

 The heading elements are H1, H2, H3, H4, H5, and H6 with H1 being the highest (or 

most important) level and H6 the least. 

• logo or icon authorship information 

You can have several header elements in one document. 
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Creating Lists 
You can add new list by choosing Insert and then selecting the desired option, unordered list, ordered 

list or list item. 

 

 

You can change / modify an existing list item by clicking in the list, and then select the edit option from 

the drop down menu 
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Exercise 3. Inserting and formatting Lists 
 

1. Open Microsoft Word and create a new document. Type a few sentences and save the file as 

DW_Exercises. Do not close Microsoft Word after saving 

2. Open your saved file from the previous exercise, DW_Exercises.html 

3. Insert a header to your page. For the header, type in your name.  

4. Insert a new paragraph and copy and paste the text from the work document into the newly 

inserted paragraph 

5. Below your new paragraph, create a bulleted list and a numbered list 

a. In the bulleted list, create 5 bullets listing your favorite things to do 

b. In the numbered list, list your five of your favorite music artist, movies, or books starting 

in descending order. 
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Images, Hyperlinks, and more 

Working with Images 
It is important that you prepare your images before inserting them into your Web pages.  Use a graphics 

editor, like Adobe Photoshop elements to optimize and resize your images for use on the Web. Save 

your files as either GIF or JPG files in the images folder within the site folder. 

Image sizes onscreen and in print  
The size of an image when you view it onscreen is different from its size when you print it. If you 

understand these differences, you can develop a better understanding of which settings to change when 

you resize an image. 

Screen size  
The screen resolution of your monitor is the number of pixels it can display. For example, a monitor with 

a screen resolution of 640 x 480 pixels displays 640 pixels for the width and 480 pixels for the height. 

There are several different screen resolutions you can use, and the physical size of the monitor screen 

usually determines the resolutions available. For example, large monitors typically display higher 

resolutions than small monitors because they have more pixels. 

To find out what your screen resolution is, choose Start > Control Panel > Display > Settings and look at 

the screen resolution (Windows), or choose System Preferences > Displays and look in the Resolution list 

(Mac OS). 

Image size onscreen  
Images are of a fixed pixel size when they appear on your monitor. Your screen resolution determines 

how large the image appears onscreen. A monitor set to 640 x 480 pixels displays fewer pixels than a 

monitor displaying 1024 x 768 pixels. Therefore, each of the pixel on the 640 x 480 pixel monitor is 

larger than each pixel displayed on the 1024 x 768 pixel monitor. 

A 100 x 100-pixel image uses about one-sixth of the screen at 640 x 480, but it takes up only about one-

tenth of the screen at 1024 x 768. Therefore, the image looks smaller at 1024 x 768 pixels than at 640 x 

480 pixels. 

Image size in print  
The other values used in resizing images—the physical size of the image when printed, and the 

resolution—aren't used until the image is printed. Then, the physical size of the image, the resolution, 

and the pixel dimensions determine the amount of data in the image and its print quality. In general, 

higher resolution images print at a higher quality. See the sections that follow for more information on 

resolution and physical size. 
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Image Size dialog box  
When you use the Image Size dialog box to resize your images (choose Image > Image Size), four aspects 

of your image can change: 

 Pixel dimensions: The width and height of the image. 

 Image size when it's open in Photoshop: This value appears at the top of the dialog box. 

 Document size: Physical size of the image when printed, including a width and height. 

 Image resolution when printed: This value appears in pixels per inch or pixels per centimeter. 

Photoshop calculates the physical size, resolution, and pixel dimensions of an image as follows: 

 Physical size = resolution x pixel dimensions 

 Resolution = physical size / pixel dimensions 

 Pixel dimensions = physical size / resolution 

The Image Size dialog box allows you to resize your images in two ways. You can increase or decrease 

the amount of data in the image (resampling). Or, you can maintain the same amount of data in the 

image (resizing without resampling). When you resample, the image quality can degrade to some 

extent. You may have to do some extra work, such as using the Unsharp Mask filter to sharpen your 

image, to compensate for the resampling. 

Tip: To reset the Image Size dialog box to its original state, press Alt (Windows) or Option (Mac OS). 

Pressing these keys changes the Cancel button to a Reset button. 

Resizing and resampling images  
When you resize and resample an image, you change the amount of data in that file. To resample your 

image, ensure that Resample is selected at the bottom of the Image Size dialog box. Resample is on by 

default. 

Resampling changes the total number of pixels in the image, which are displayed as Width and Height in 

pixels in the Image Size dialog box. When you increase the number of pixels in this part of the dialog box 

(upsampling), the application adds data to the image. When you decrease the number of pixels 

(downsampling), the application removes data. Whenever data is removed from or added to the image, 

the image quality degrades to some extent. Removal of data from an image is typically preferable to the 

addition of data. That's because upsampling requires that Photoshop guess which pixels to add. This 

procedure is more complex than guessing which pixels to remove when you downsample. You get the 

best results working with images you bring into Photoshop in the proper resolution for the output you 

want. You could get the results you need by resizing your image without resampling. However, if you 

resample your images, do so only once. 

When you turn on Resample, you can change any of the values in the Image Size dialog box: pixel 

dimensions, physical size, or resolution. If you change one value, you affect the others. The pixel 

dimensions are always affected. 

 Changing the pixel dimensions affects the physical size but not the resolution. 

 Changing the resolution affects the pixel dimensions but not the physical size. 

 Changing the physical size affects the pixel dimensions but not the resolution. 
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You cannot set the file size; it changes when you change the total amount of data in the image (the pixel 

dimensions). Note the file size value before you change the other values in the dialog box. Then, you can 

use the file size information to understand how much data is removed or added to your image when you 

resample it. For example, if the file size changes from 250 KB to 500 KB, you add twice as much data to 

the image, which can degrade it. Degraded images can look blurry, jagged, or blocky. 

Resizing images without resampling  
When you resize an image and do not resample it, you change the image's size without changing the 

amount of data in that image. Resizing without resampling changes the image's physical size without 

changing the pixel dimensions in the image. No data is added to or removed from the image. When you 

deselect, or turn off, Resample, the pixel dimension fields are not available. The only two values you can 

change are the physical size (Width and Height in Document Size) or the resolution (pixels/inch). When 

you resize without resampling, you can set either the physical size or the resolution of the image. To 

keep the total amount of pixels in the image the same, Photoshop compensates for the value you set by 

increasing or decreasing the other value. For example, if you set the physical size, Photoshop changes 

the resolution. 

When the pixel dimensions are constant and you decrease the physical size of an image, the resolution 

increases correspondingly. If you decrease the physical size of an image by half, the resolution doubles. 

Twice as many pixels can fit into the same space. If you double the size of an image, the resolution 

decreases by half, because the pixels are twice as far apart to fit the physical size. 

For example, a 400 x 400-pixel image, has a physical size of 4 x 4 inches and has a resolution of 100 

pixels per inch (ppi). To reduce the image's physical size by half without resampling, you set the physical 

size to 2 x 2 inches. Photoshop increases the resolution to 200 ppi. Resizing the image this way keeps the 

total number of pixels constant (200 ppi x 2 x 2 inches = 400 x 400 pixels). If you double the physical size 

(to 8 x 8 inches), the resolution decreases to 50 ppi. Adding more inches to the image size means that 

there can only be half as many pixels per inch. If you change the image resolution, the physical size 

changes as well. 

Important: The pixel dimensions control the amount of data, and the resolution and the physical size are 

used only for printing. 

Note: Pixels per inch (ppi) is the number of pixels in each inch of the image. Dots per inch (dpi) relates 

only to printers, and varies from printer to printer. Generally, there are 2.5 to 3 dots of ink per pixel. For 

example, a 600-dpi printer only requires a 150- to 300-ppi image for best quality printing. 

Using the Crop tool  
When you use the Crop tool to resize an image, the pixel dimensions and the file size change but the 

image isn't resampled. When you use the Crop tool, the pixel dimensions and resolution incorporate 

more pixels per inch based on the size of the crop region. However, Photoshop isn't specifically adding 

or removing data from the image. 

When you crop an image, you remove data from or add data to the original image size to create a 

different image. Because you are removing or adding data relative to the original image, the concept of 

resampling loses much of its meaning. That's because the number of pixels per inch can vary based on 

the number of pixels in the crop selection area. When the number of pixels in the crop area allows, 



 Winthrop University – Technology Services - Spring 2018 
An introduction to Dreamweaver 33 

Photoshop tries to keep the same resolution of the original image. This method is considered cropping 

without resampling. However, when you are not exact about the number of pixels you select, the pixel 

dimensions and file size changes in the new image. 

Crop tool options  
The options in the Crop tool options bar change after you draw the selection area. When you first select 

the Crop tool, you can specify a width, height, and resolution. You can measure the width and height in 

inches, centimeters, millimeters, points, and picas. Type the unit or the unit abbreviation after the 

number in the value field. For example, 100 px, 1 in, 1 inch, 10 cm, 200 mm, 100 pt, or 100 pica. If you 

do not specify a unit of measure in the Width and Height fields in the Crop options bar, the default unit 

is inches. 

You can also set a value for the resolution of the cropped image in the Resolution field. Choose 

pixels/inch or pixels/cm from the pop-up menu. 

 

Notes: 
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Hyperlinks 
A hyperlink is a word, phrase, or image that you can click on to jump to a new document or a new 

section within the current document. Hyperlinks are found in nearly all Web pages, allowing users to 

click their way from page to page. Text hyperlinks are often blue and underlined, but don't have to be. 

When you move the cursor over a hyperlink, whether it is text or an image, the arrow should change to 

a small hand pointing at the link. When you click it, a new page or place in the current page will open. 

Link to documents using the Property inspector  
You can use the Property inspector’s folder icon or Link box to create links from an image, an object, or 

text to another document or file.  

1. Select text or an image in the Document window’s Design view. 

2. Open the Property inspector (Window > Properties) and do one of the following: 

a. Click the folder icon to the right of the Link box to browse to and select a file. 

b. The path to the linked document appears in the URL box. Use the Relative To pop‑up 

menu in the Select File dialog box to make the path document-relative or root-relative, 

and then click OK. The type of path you select applies only to the current link. (You can 

change the default setting of the Relative To box for the site.) 

c. Type the path and filename of the document in the Link box. 

d. To link to a document in your site, enter a document-relative or site root–relative path. 

To link to a document outside your site, enter an absolute path including the protocol 

(such as http://). You can use this approach to enter a link for a file that hasn’t been 

created yet. 

3. From the Target drop-down list, select a location in which to open the document: 

a. _blank loads the linked document in a new, unnamed browser window. 

b. _parent loads the linked document in the parent frame or parent window of the frame 

that contains the link. If the frame containing the link is not nested, then the linked 

document loads in the full browser window. 

c. _self loads the linked document in the same frame or window as the link. This target is 

the default, so you usually don’t have to specify it. 

d. _top loads the linked document in the full browser window, thereby removing all 

frames. 

e. _new loads the linked document in a new window. 

Link to documents using the Point-To-File icon  
1. Select text or an image in the Document window’s Design view. 

2. Create a link in one of two ways: 

a. Drag the Point-To-File icon   (target icon) at the right of the Link box in the Property 

inspector and point to a visible anchor in the current document, a visible anchor in 

another open document, an element that has a unique ID assigned to it, or a document 

in the Files panel. 

b. Shift-drag from the selection and point to a visible anchor in the current document, a 

visible anchor in another open document, an element that has a unique ID assigned to 

it, or a document in the Files panel. 
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Add a link using the Hyperlink command  
The Hyperlink command lets you create a text link to an image, an object, or to another document or 

file. 

1. Place the insertion point in the document where you want the link to appear. 

2. Do one of the following to display the Hyperlink dialog box: 

a. Select Insert > Hyperlink. 

b. In the Common category of the Insert panel, click the Hyperlink button. 

3. In the Text field, enter the text of the link. 

From the Link drop-down menu, select the name of the file to link to. You can also click the 

folder icon to browse to the file you want to link to. 

4. In the Target pop‑up menu, select the window in which the file should open or type its name. 

The names of all the frames you’ve named in the current document appear in the pop‑up list. If 

you specify a frame that doesn’t exist, the linked page opens in a new window that has the 

name you specified. You can also select from the following reserved target names: 

a. _blank loads the linked file into a new, unnamed browser window. 

b. _parent loads the linked file into the parent frameset or window of the frame that 

contains the link. If the frame containing the link is not nested, the linked file loads into 

the full browser window. 

c. _self loads the linked file into the same frame or window as the link. This target is the 

default, so you usually don’t need to specify it. 

d. _top loads the linked file into the full browser window, thereby removing all frames. 

e. _new loads the linked document in a new window. 

5. In the Tab Index box, enter a number for the tab order. 

6. In the Title box, enter a title for the link. 

7. In the Access Key box, enter a keyboard equivalent (one letter) to select the link in the browser. 

8. Click OK. 

 

Notes: 
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Create link to a Word or Excel document  
You can insert a link to a Microsoft Word or Excel document in an existing page. 

1. In Design view, open the page where you want the link to appear. 

2. Drag the file from its current location to your Dreamweaver page, positioning the link wherever 

you want. 

The Insert document dialog box appears. 

 

 

                 Figure 1 - Linking to a Word or Excel document 

3. Select Create A Link, and then click OK. 

If the document you are linking to is located outside of your site’s root folder, Dreamweaver 

prompts you to copy the document to the site root. 

By copying the document to the site’s root folder, you ensure that the document will be 

available when you publish the website. 

 

4. When you upload your page to your web server, make sure to upload the Word or Excel file, 

too. Your page now contains a link to the Word or Excel document. The link text is the name of 

the linked file; you can change the link text in the Document window if you wish.  
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Create an e‑mail link  
An e‑mail link opens a new blank message window (using the mail program associated with the user’s 

browser) when clicked. In the e‑mail message window, the To box is automatically updated with the 

address specified in the e‑mail link. 

Create an e-mail link using the Insert Email Link command  
1. In the Document window’s Design view, position the insertion point where you want the e-mail 

link to appear, or select the text or image you want to appear as the e-mail link. 

2. Do one of the following to insert the link: 

a. Select Insert > Email Link. 

b. In the Common category of the Insert panel, click the Email Link button. 

3. In the Text box, type or edit the body of the e-mail. 

4. In the Email box, type the e-mail address, then click OK. 

 

Test links in Dreamweaver  
Links are not active within Dreamweaver; that is, you cannot open a linked document by clicking the link 

in the Document window. 

1. Do one of the following: 

a. Right-click on the link and select Open Linked Page. 

b. Press Control (Windows) or Command (Macintosh) and double-click the link. 
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Layout and Design 

Cascading Style Sheets 
Cascading Style Sheets (CSS) is a collection of formatting rules that control the appearance of content in 

a web page. Using CSS styles to format a page separates content from presentation. The content of your 

page—the HTML code—resides in the HTML file, and the CSS rules defining the presentation of the code 

reside in another file (an external style sheet) or in another part of the HTML document (usually the 

head section). Separating content from presentation makes it much easier to maintain the appearance 

of your site from a central location because you don’t need to update every property on every page 

whenever you want to make a change. Separating content from presentation also results in simpler and 

cleaner HTML code, which provides shorter browser loading times, and simplifies navigation for people 

with accessibility issues (for example, those using screen readers). 

CSS gives you great flexibility and control over the exact appearance of your page. With CSS you can 

control many text properties including specific fonts and font sizes; bold, italics, underlining, and text 

shadows; text color and background color; link color and link underlining; and much more. By using CSS 

to control your fonts, you can also ensure a more consistent treatment of your page layout and 

appearance in multiple browsers. 

In addition to text formatting, you can use CSS to control the format and positioning of block-level 

elements in a web page. A block-level element is a standalone piece of content, usually separated by a 

new line in the HTML, and visually formatted as a block. For example, h1 tags, p tags, and div tags all 

produce block-level elements on a web page. You can set margins and borders for block-level elements, 

position them in a specific location, add background color to them, float text around them, and so on. 

Manipulating block-level elements is in essence the way you lay out pages with CSS. 

About text formatting and CSS  
By default, Dreamweaver uses Cascading Style Sheets (CSS) to format text. The styles that you apply to 

text using the Property inspector or menu commands create CSS rules that are embedded in the head of 

the current document. 

You can also use the CSS Designer to create and edit CSS rules and properties. The CSS Designer is a 

much more robust editor than the Property inspector, and displays all CSS rules defined for the current 

document, whether those rules are embedded in the head of the document or in an external style 

sheet. Adobe recommends that you use the CSS Designer (rather than the Property inspector) as the 

primary tool for creating and editing your CSS. As a result, your code will be cleaner and easier to 

maintain. 

For more information on CSS Designer, see Laying out pages using CSS Designer. 

In addition to styles and style sheets you create, you can use style sheets that come with Dreamweaver 

to apply styles to your documents. 
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The CSS specification allows for the creation of styles using an abbreviated syntax known as shorthand 

CSS. Shorthand CSS lets you specify the values of several properties using a single declaration. For 

example, the font property lets you set font-style, font-variant, font-weight, font-size, line-height, and 

font-family properties on a single line. 

A key issue to note when using shorthand CSS, is that values omitted from a shorthand CSS property are 

assigned their default value. This may cause pages to be incorrectly displayed when two or more CSS 

rules are assigned to the same tag. 

When written using shorthand notation, omitted values are automatically assigned their default values. 

Thus, the previous shorthand example omits the font-variant, font-style, font-stretch, and font-size-

adjust tags. 

If you have styles defined in more than one location (for example, both embedded in an HTML page and 

imported from an external style sheet) using both the short and long forms of CSS syntax, be aware that 

omitted properties in a shorthand rule may override (or cascade) properties that are explicitly set in 

another rule. 

For this reason, Dreamweaver uses the long form of CSS notation by default. This prevents possible 

problems caused by a shorthand rule overriding a longhand rule. If you open a web page that was coded 

with shorthand CSS notation in Dreamweaver, be aware that Dreamweaver will create any new CSS 

rules using the longhand form. You can specify how Dreamweaver creates and edits CSS rules by 

changing the CSS editing preferences in the CSS Styles category of the Preferences dialog box (Edit > 

Preferences in Windows; Dreamweaver > Preferences on the Macintosh). 
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About CSS page layout structure  
Before proceeding with this section, you should be familiar with basic CSS concepts. 

The basic building block of the CSS layout is the div tag—an HTML tag that in most cases acts as a 

container for text, images, and other page elements. The following example shows an HTML page that 

contains three separate div tags: one large “container” tag, and two other tags—a sidebar tag, and a 

main content tag—within the container tag.  

A. Container div B. Sidebar div C. Main Content div   
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Where to find Help in Dreamweaver 
There are varieties of ways to find help in Dreamweaver 

Click the Help Drop down menu from the Dreamweaver menu bar 

Press the “F1” key and this opens a browser to the Adobe Dreamweaver Help and Support site 
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Resources 
Books on Dreamweaver and HTML 

Adobe Dreamweaver CS6 Bible, The comprehensive, tutorial resource. By Joseph Lowery 

Useful YouTube Video link(s)  

https://www.youtube.com/watch?v=D-5xpY4zH2c  

https://www.youtube.com/watch?v=dCzjFrgyMS0  

https://www.youtube.com/watch?v=8AqTyjm7brA  

https://www.youtube.com/watch?v=ORV1HOSgv2Q  

 

https://www.youtube.com/watch?v=D-5xpY4zH2c
https://www.youtube.com/watch?v=dCzjFrgyMS0
https://www.youtube.com/watch?v=8AqTyjm7brA
https://www.youtube.com/watch?v=ORV1HOSgv2Q

